0
На рассмотрении

Визуальное выделение обработанных документов в Модуле интеграции 1С

Акопова Татьяна Михайловна 5 месяцев назад • обновлен Петухов Антон (Специалист поддержки) 4 месяца назад 2

Добрый день. Для более удобной визуализации уже обработанных документов в модуле 1С добавил несколько строчек кода в процедуру "ПриВыводеСтрокиПакета" Формы "Форма_Основная":


Если ДанныеСтроки.ЗначениеСостояниеДокументооборота = "Документооборот завершен"                          ИЛИ ДанныеСтроки.ЗначениеСостояниеДокументооборота = "Подписан" Тогда
      Для каждого ЯчейкаСтроки из ОформлениеСтроки.Ячейки Цикл
            Если НЕ ЯчейкаСтроки.Имя = "КартинкаДокументаВПакете" Тогда
                    ЯчейкаСтроки.ЦветФона = Новый Цвет(204, 255, 204);
             КонецЕсли;
      КонецЦикла;
КонецЕсли;


В результате чего при открытии и работе с формой отображение данных приобрело следующий вид.


Пользователи оценили. Это также удобно в дополнение к  выполнению дополнительных действий при установке фильтра о статусе документа. Буду рад, если мое предложение получит отклик и будет реализовано в последующих обновлениях модуля.


На рассмотрении

Добрый день.

Спасибо за информацию.

Передали на рассмотрение.

Пожелание зафиксировано. 

Информации о возможности/сроках реализации пока нет.

Если ваше пожелание наберет большое количество голосов, приоритет рассмотрения будет повышен.

Спасибо.

Сервис поддержки клиентов работает на платформе UserEcho