0
Отвечен

MERC56087 Дата окончания срока годности продукции указана неверно

Сергей Елышев 2 года назад в Ошибки MERC обновлен Malinskaya 2 года назад 1

Проблема с установкой срока годности:

При формировании производственной партии на непищевую продукцию (4101 шкуры КРС (8a460a3a-2a29-19e5-944d-805c4e264f74)) возвращается ошибка "MERC56087 Дата окончания срока годности продукции указана неверно." 
Какой бы срок я не указывал, результат один и тот же. Если срок не установлен вообще, то сам модуль Контур.Меркурий не позволяет отправить документ. Если убрать в коде модуля контроль заполнения срока и оставить дату пустой, то меркурий возвращает другую ошибку "MERC56083 Дата окончания срока годности продукции обязательна для заполнения."
Подскажите, какова логика работы системы меркурий при проверке срока годности. 

Ответ

Ответ
Отвечен

Добрый день!


Для данной продукции необходимо указать срок годности "не ограничен".

По данному функционалу создана задача в разработку (E1C_in-104126), её статус Вы можете уточнить, позвонив в техподдержку.


В качестве временного решения:

1. Указываем у данной продукции срок годности с годом "2999".
2. В подключаемом модуле задействуем плагин

Функция Плагин_МеркурийИзменитьИсходящееСообщениеXDTO(ИмяСобытия, Параметры, СтандартнаяОбработкаEDI = Истина)
    
    Если ИмяСобытия = "МеркурийИзменитьСообщениеXDTO_20" Тогда
        
        Для Каждого productiveBatch из Параметры.ПараметрыТранзакции.productionOperation.productiveBatch Цикл    
            
            Если productiveBatch.expiryDate <>неопределено И
                productiveBatch.expiryDate.firstDate.year = 2999 Тогда
                productiveBatch.expiryDate.informalDate = "не ограничен";
            КонецЕсли;
            
        КонецЦикла;    
        
    КонецЕсли;
    
КонецФункции

Ответ
Отвечен

Добрый день!


Для данной продукции необходимо указать срок годности "не ограничен".

По данному функционалу создана задача в разработку (E1C_in-104126), её статус Вы можете уточнить, позвонив в техподдержку.


В качестве временного решения:

1. Указываем у данной продукции срок годности с годом "2999".
2. В подключаемом модуле задействуем плагин

Функция Плагин_МеркурийИзменитьИсходящееСообщениеXDTO(ИмяСобытия, Параметры, СтандартнаяОбработкаEDI = Истина)
    
    Если ИмяСобытия = "МеркурийИзменитьСообщениеXDTO_20" Тогда
        
        Для Каждого productiveBatch из Параметры.ПараметрыТранзакции.productionOperation.productiveBatch Цикл    
            
            Если productiveBatch.expiryDate <>неопределено И
                productiveBatch.expiryDate.firstDate.year = 2999 Тогда
                productiveBatch.expiryDate.informalDate = "не ограничен";
            КонецЕсли;
            
        КонецЦикла;    
        
    КонецЕсли;
    
КонецФункции

Сервис поддержки клиентов работает на платформе UserEcho