0
Отвечен

Сопоставление ХС организации

tolik44 1 год назад обновлен Ольга К 1 год назад 46

Доброго времени суток. Интегрирую модуль меркурий в 1С Бухгалтерия сельскохозяйственного предприятия. Столкнулся с проблемой: При настройке соответствия организации и площадки справа площадки организации не выходят, по кнопке зарегистрированные площадки доступны. При выборе их ни чего не происходит

+1
На рассмотрении

Добрый День!

если я правильно понимаю проблему, то вам необходимо сделать следующее: зайти в настройки гис меркурий, сопоставить организацию, закрыть карточку сопоставления. выбрать строку с нужной организацией, нажать подробнее и сопоставить площадку двойным кликом на столбец объект 1С. закрыть карточку сопоставления. площадки появятся в списке.

подробное описание в разделе инструкции Настройка - соответствие контрагентов

Все делаю согласно инструкции. Если в настройке контрагента нажать кнопку подробнее то площадки отображаются, но сопоставление не происходит

+1

нажмите кнопку подробнее и сделайте скриншот

+1

версии модулей еди и меркурия сообщите, пожалуйста

EDI

Меркурий и площадки

при попытке создать площадку при вводе адреса дает такую вот ошибку


{ВнешняяОбработка.КонтурМеркурий.МодульОбъекта(42553)}: Поле объекта недоступно для записи (Дополнение)
Дополнение = ?(ПустаяСтрока(Форма.МеркурийКИ_country.fullName), Форма.МеркурийКИ_country.name, Форма.МеркурийКИ_country.fullName);

+1

как только вы заполните столбец объект 1с , то есть сопоставите площадки меркурия со складами 1С, площадки появятся в списке.

Для сопоставления необходимо встать на строчку и нажать Enter? Пробовал не получается

нужно дважды кликнуть мышкой на столбец объект 1С

Пробовал не получается

+1

что происходит когда дважды нажимаете на столбец объект 1С? какая ошибка? 

я сопоставляла площадки на управляемых формах в модуле версии 12.001, все работает корректно.

без подключения сложно сказать что вы делаете неверно.

позвоните в нашу техподдержку, ребята подключаться и помогут сопоставить площадки. телефон техподдержки 8-800-250-49-27

Ни чего не происходит просто крутит немного курсор и все

+1

Нужно сделать настройки в ПМ:
1. В событии "МеркурийИзменитьТипыПлощадок" указать возможные типы площадок (например МассивТипов.Добавить(Тип("СправочникСсылка.Партнеры")))
2. В событии "МеркурийПриПодготовкеТранзакции" указать реквизиты документа, которые соответствуют площадкам

Как я понял ОбработкаСобытияПодключаемогоМодуля("МеркурийИзменитьТипыПлощадок",, Новый Структура("МассивТипов", МассивТипов.Добавить(Тип("СправочникСсылка.Партнеры"))));

со вторым не совсем понял


+1

в модуле на закладке служебная есть возможность скачать шаблон подключаемого модуля.

откройте шаблон в конфигураторе и выполните поиск события МеркурийПриПодготовкеТранзакции, там есть пример кода.

не выгружает ПМ

+1

отправили вам на почту

Как я понял в Функция Плагин_МеркурийПриПодготовкеТранзакции?

бработкаСобытияПодключаемогоМодуля("МеркурийИзменитьТипыПлощадок",, Новый Структура("МассивТипов", МассивТипов.Добавить(Тип("СправочникСсылка.Партнеры")))); ни чего недало

+1

Приведите код целиком

Функции Плагин_МеркурийПриПодготовкеТранзакции

Что написан вами

Пока его не писал не могу сообразить. Под 1с разработкой заниматься не приходилось

Сообщение = Параметры.Сообщение;

ДокументСсылка = Параметры.ДокументСсылка;

ПараметрыТранзакции = Параметры.Параметры;



Если Сообщение.ТипСообщения = "M_REC" Тогда
//
Сообщение.Площадка1С = ДокументСсылка.Контрагент;

В пм не могу найти МеркурийИзменитьТипыПлощадок

Надо раскомментировть  плагин: 

Результат = Плагин_МеркурийНестандартнаяКонфигурация(ИмяСобытия, Параметры, СтандартнаяОбработкаEDI);

Если Не Результат = Неопределено Тогда

Возврат Результат

КонецЕсли;

В моем примере за площадку в базе отвечает справочник ВиртуальныеСклады, вот такой  код использую: 

//УФ
Если ИмяСобытия = "МеркурийИзменитьТипыПлощадок" Тогда
МассивТипов = Параметры.МассивТипов;
МассивТипов.Добавить(Тип("СправочникСсылка.ВиртуальныеСклады"));
Возврат МассивТипов;
КонецЕсли;
//УФ

Надо раскомментировть  плагин: 

Результат = Плагин_МеркурийНестандартнаяКонфигурация(ИмяСобытия, Параметры, СтандартнаяОбработкаEDI);

Если Не Результат = Неопределено Тогда

Возврат Результат

КонецЕсли;

В моем примере за площадку в базе отвечает справочник ВиртуальныеСклады, вот такой  код использую: 

//УФ
Если ИмяСобытия = "МеркурийИзменитьТипыПлощадок" Тогда
МассивТипов = Параметры.МассивТипов;
МассивТипов.Добавить(Тип("СправочникСсылка.ВиртуальныеСклады"));
Возврат МассивТипов;
КонецЕсли;
//УФ

В моем примере за площадку в базе отвечает справочник ВиртуальныеСклады

Это в конфигурации или обработке


{ВнешняяОбработка.КонтурEDI.МодульОбъекта(3091)}: Ошибка при вызове метода контекста (Создать): Ошибка подключения внешних метаданных: Файл не обнаружен 'C:\EDI\КонтурEDI_ПодключаемыйМодульМеркурий_Шаблон .epf'


не могу найти данную строчку

необходимо нажать на значок шестеренки - выбрать настройки - подключаемый модуль - указать путь к подключаемому модулю в справочнике 1С. сохранить изменения.

В моем примере за площадку в базе отвечает справочник ВиртуальныеСклады

Это в конфигурации или обработке


Доработка пока особых изменений не дала

В базе у меня есть  справочник ВируальныеСклады (у вас может быть справочник ДоговорыКотрагентов, ТочкиДоставки и т.д и т.п )  А код вношу в обработку КонтурEDI_ПодключаемыйМодульМеркурий_Шаблон.epf' 

Вы можете более детально изучить работу с КонтурEDI_ПодключаемыйМодульМеркурий_Шаблон в разделе инструкции Подключаемый модуль-Описание

Это может быть из платформы 1с?

необходимо нажать на значок шестеренки - выбрать настройки - подключаемый модуль - указать путь к подключаемому модулю в справочнике 1С (к примеру дополнительные обработки ). сохранить изменения.

Естественно, предварительно надо в дополнительные обработки КонтурEDI_ПодключаемыйМодульМеркурий_Шаблон добавить

Все сделал как вы сказали результат тотже

Проблема с сопоставлением понятна в процедуре ПривязанныеПлощадкиВыбор в обработке контурМеркурий:ПросмотрХСУ Управлемая переменная ХозСубъектEDI_ получает пустое значение помогите разобраться

Вам удалось подключить обработку КонтурEDI_ПодключаемыйМодульМеркурий_Шаблон.epf ?

Ау ответьте кто нибудь

Прошу ответить на вопрос Ирины.

Шаблон подключить удалось.


Подскажите из какого справочника нужно брать сопоставление для ХС и для площадки? 

для своей организации справочник организации для контрагентов справочник контрагенты

А ошибка все еще осталась?
Да
Проблема с сопоставлением понятна в процедуре ПривязанныеПлощадкиВыбор в обработке контурМеркурий:ПросмотрХСУ Управлемая переменная ХозСубъектEDI_ получает пустое значение помогите разобраться

1) подскажите у вас в Меркурии не зарегистрирована нужная площадка - именно по этому вы пытаетесь ее создать или для каких - то других целей?

2) верно ли я поняла что вся проблема в том, что не создается площадка?

ответа от вас не поступило. проблема не актуальна?

Сервис поддержки клиентов работает на платформе UserEcho