+2
Отвечен

Перестали заполняться поля входящих ВСД в списке операций

Александр Трапезников 9 месяцев назад обновлен Ольга К 7 месяцев назад 18

Как было М8.15.04

Как стало в М8.16.02

Перестали заполняться Дата и Точка доставки, и неверно заполняется Партнёр. Отключал все расширения и подключаемый модуль, результата нет. Это на откуп пользователю? Пусть заполняет на своё усмотрение?

У меня версия EDI 4.03.31.02 всё нормально заполняется.
Попробуйте обновить.

+2
На рассмотрении

добрый день,
зарегистрировано обращение E1C_in-117352

Подтверждаю в М8.16.02 тоже самое ((

Александр, с Вами эти "партнеры" работают по EDI?
У меня OZON - просто как торговая сеть подключен, но с ним пока не работаем по EDI и он единственный стал подставляться вместо Меркурия, как партнер.  

+1

это баг, он будет исправлен, задача у разработки есть

Группировка входящих ВСД, например по номеру ТТН или Госномеру, тоже из-за этого перестала работать?

у меня работает группировка входящих у всез клиентов на 16.01, 02, 03.

в настройках входящих сообщений после обновления проверьте галочки

группировка у вас как сломалась? каждый ВСД отдельно или какие-то отдельно, а какие-то в пачках?

Галочки в настройках так же, как у Вас.

+1

временное решение по проблеме Неверного партнера для входящих ВСД 

Функция ОпределитьПартнераEDIПоСообщениюМеркурий(Знач Сообщение)
    
    Перем ТочкаДоставки, ТочкаДоставкиПолностью;
    
    ПартнерEDI = Неопределено;
    
...
        
        //для определения Партнера - воспользуемся EDI логикой
        Если ЗначениеЗаполнено(Сообщение.ХозяйствующийСубъектПолучатель1С) Тогда 
            ПартнерEDI = ОсновнойМодуль.ПолучитьЗначениеСвойстваОбъектаEDI(Сообщение.ХозяйствующийСубъектПолучатель1С, "ПартнерКонтрагента");
        КонецЕсли;
        Если НЕ ЗначениеЗаполнено(ПартнерEDI) И ЗначениеЗаполнено(Сообщение.ПлощадкаПолучатель1С) Тогда 
            ПартнерEDI = ОсновнойМодуль.ПолучитьЗначениеСвойстваОбъектаEDI(Сообщение.ПлощадкаПолучатель1С, "ПартнерКонтрагента");
        КонецЕсли;
        
        //+++СКБ_КОНТУР_СЕВ_20062019
        //Если НЕ ЗначениеЗаполнено(ПартнерEDI) Тогда        //БЫЛО
        Если НЕ ЗначениеЗаполнено(ПартнерEDI) И ЗначениеЗаполнено(Сообщение.ПлощадкаПолучатель1С) Тогда //СТАЛО
        //---СКБ_КОНТУР_СЕВ_20062019    
            ТочкаДоставки = ОсновнойМодуль.НайтиОбъектПоЗначениюСвойства("ЮрФизЛицо_ТочкиДоставки",Сообщение.ПлощадкаПолучатель1С);
            Если ЗначениеЗаполнено(ТочкаДоставки) Тогда
                ТочкаДоставкиПолностью = ОсновнойМодуль.ПолучитьЭлементСправочника("ТочкиДоставкиСторонние",ТочкаДоставки);
                ПартнерEDI = ТочкаДоставкиПолностью.Партнер;
            КонецЕсли;
        КонецЕсли;
        
    КонецЕсли;
    
    Возврат ПартнерEDI;
    
КонецФункции

Спасибо, Ольга!
Данное решение, устраняет "кривого" партнера и  корректно отрабатывает группировка входящих ВСД.
Остальные поля в списке из основного топика по прежнему остаются пустыми:

+1

Партнер стал Меркурий, спасибо. 

Но поля в списке так и не заполняются, ну это похоже баг более глобальный...

Да, это временное решение вопроса.

М8.16.03  та же ситуация, в модуле EDI есть сеть караван(партнер), так вот он ее ставит вместо Меркурий для входящих всд, и данные в списке не отображаются.

Отвечен

проблема заполнения столбцов исправлена в версии 17.01

+1

Получать новые релизы через поддержку или менеджера не очень удобно. Раньше в Телеграм выкладывали. Сейчас там закреплённое сообщение с ссылкой на старый релиз. Будут публиковать новые релизы в Телеграм?

17 релиз находится в тестировании. в массы мы его пока не отдаем

Сервис поддержки клиентов работает на платформе UserEcho