0
Не ошибка

не запускается КонтурEDI (curl_easy_perform SSL connect error) Модуль_КонтурПлагин (РЕШЕНО)

Сергей Кравец 7 месяцев назад обновлен Елизавета 7 месяцев назад 2

При попытке запустить КонтурEDI выскакивает ошибка: {ВнешняяОбработка.Модуль_КонтурПлагин.МодульОбъекта(1961)}: Ошибка Kontur.1C.Plugin.Host message : LIBCURL[0x00000023]curl_easy_perform SSL connect error

При чем, что интересно, на машине с виндой 10 все работает. Ошибка возникает на сервере 2003.

Ругается на модуль КонтурПлагин. 

Галочка "Использовать контур плагин" никак на ситуацию не влияет.

Все ресурсы интернета открыты.

Как выяснилось, разработчики использовали в коде такую вещь:

Если Галочка поставлена, ИЛИ Версия 1с меньше чем 8.2.19.130 Тогда - использовать этот, не работающий на 2003 сервере плагин.

РЕШЕНИЕ:

Находим в модуле объекта код:

Если ИспользоватьКонтурPlugin = Истина
ИЛИ НЕ ВерсияПрограмногоПродуктаРавнаИлиВыше(ВерсияПлатформы1С, "8.2.19.130") Тогда

И меняем его на 

Если ИспользоватьКонтурPlugin = Истина Тогда

// ИЛИ НЕ ВерсияПрограмногоПродуктаРавнаИлиВыше(ВерсияПлатформы1С, "8.2.19.130") Тогда

Тогда неработающий модуль не запускается, если не стоит галочка "Использовать контур плагин" в настройках. 

Ответ

Ответ
Не ошибка

Спасибо, но требования для работы модуля - платформа 1С  = 8.2.19.130 или выше

  • Одна из операционных систем компании Microsoft:
    • Windows XP с пакетом обновления 2 (SP2) и выше;
    • Windows Server 2003 с пакетом обновления 1 (SP1) и выше:
      1. Если Server 2003, то должны стоять заплатки от windows:
        1. WindowsServer2003-KB938397-x86-RUS
        2. WindowsServer2003-KB948963-x86-RUS
        3. WindowsServer2003-KB968730-x86-RUS

    • Windows Vista с пакетом обновления 1 (SP1) и выше;
    • Windows 7;
    • Windows 2008 (в том числе R2).
Ответ
Не ошибка

Спасибо, но требования для работы модуля - платформа 1С  = 8.2.19.130 или выше

  • Одна из операционных систем компании Microsoft:
    • Windows XP с пакетом обновления 2 (SP2) и выше;
    • Windows Server 2003 с пакетом обновления 1 (SP1) и выше:
      1. Если Server 2003, то должны стоять заплатки от windows:
        1. WindowsServer2003-KB938397-x86-RUS
        2. WindowsServer2003-KB948963-x86-RUS
        3. WindowsServer2003-KB968730-x86-RUS

    • Windows Vista с пакетом обновления 1 (SP1) и выше;
    • Windows 7;
    • Windows 2008 (в том числе R2).

И тем не менее, у нас нет возможности поставить версию выше (конфигурация 1с при этом не работает), т.е. существуют крупные фирмы, работающие на старой платформе. Прошу это учитывать. 

Сервис поддержки клиентов работает на платформе UserEcho