0
Отвечен

Вопрос по изменениям в 17 релизе

tciban 6 месяцев назад обновлен АлександрФ 5 месяцев назад 2

Уважаемые коллеги! Посмотрел тут код регламентных заданий. Конкретно КонтурМеркурий_АвтоЛабИсследования

Суля по коду вариант, что обработка Контур.EDI может быть добавлена в конфигурацию не предусмотрен? Или я что то не понял?

Конкретно:

// АвтоЛабИсследования
Функция ЗапуститьФормированиеАвтоЛабИсследований()

Если Метаданные.РегистрыСведений.Найти("КонтурEDI_ДополнительныеРеквизиты") = Неопределено Тогда
Сообщить("Модуль Контур.EDI не обнаружен!");
Возврат Неопределено;
КонецЕсли;

МодульМеркурийТип = КонтурМеркурий_ОбщегоНазначенияСерверПовтИсп.ПолучитьКонстантуEDI("МодульМеркурийТип");

ВнешняяОбработка = Неопределено;
ИмяВременногоФайла = Неопределено;

Если МодульМеркурийТип = "1С" Тогда

МодульМеркурийGUID = КонтурМеркурий_ОбщегоНазначенияСерверПовтИсп.ПолучитьКонстантуEDI("МодульМеркурийGUID");
МодульМеркурийВидСправочника = КонтурМеркурий_ОбщегоНазначенияСерверПовтИсп.ПолучитьКонстантуEDI("МодульМеркурийВидСправочника");
Если НЕ ЗначениеЗаполнено(МодульМеркурийGUID) или НЕ ЗначениеЗаполнено(МодульМеркурийВидСправочника) Тогда
Сообщить("Модуль Контур.EDI.Меркурий не зарегистрирован!");
Возврат Неопределено;
КонецЕсли;

СсылкаНаСправочник = Справочники.ВнешниеОбработки.ПолучитьСсылку(Новый УникальныйИдентификатор(МодульМеркурийGUID));
Если НЕ ЗначениеЗаполнено(СсылкаНаСправочник) Тогда
Сообщить("Модуль Контур.EDI.Меркурий не найден! Подключите повторно.");
КонецЕсли;

ИмяВременногоФайла = ПолучитьИмяВременногоФайла("epf");
ДвоичныеДанные = СсылкаНаСправочник.ХранилищеВнешнейОбработки.Получить();
ДвоичныеДанные.Записать(ИмяВременногоФайла);
ВнешняяОбработка = ВнешниеОбработки.Создать(ИмяВременногоФайла, Ложь);

ИначеЕсли МодульМеркурийТип = "Диск" Тогда

МодульМеркурийПуть = КонтурМеркурий_ОбщегоНазначенияСерверПовтИсп.ПолучитьКонстантуEDI("МодульМеркурийПуть");
Если НЕ ЗначениеЗаполнено(МодульМеркурийПуть) Тогда
Сообщить("Модуль Контур.EDI.Меркурий не зарегистрирован!");
Возврат Неопределено;
КонецЕсли;
ВнешняяОбработка = ВнешниеОбработки.Создать(МодульМеркурийПуть, Ложь);

Иначе

Возврат неопределено;

КонецЕсли;

...

КонецФункции

Отвечен

в ближайшем будущем меркурий будет работать отдельно от модуля EDI

Сервис поддержки клиентов работает на платформе UserEcho