0
Отвечен

От куда берутся значения в колонке "Партнер"?

Дени1С 1 год назад обновлен Ольга К 1 год назад 5

Добрый день!

Во входящих ВСД вместо реального Партнера указывается какой-то произвольный.

Все сопоставления сделаны.

Как исправить?

Контур.EDI 4.03.031.02

Контур.Меркурий M8.16.03

УТ 10.3.32.1

ПЛОХО, МНЕ НЕ ПОНРАВИЛОСЬ
Оценка удовлетворенности от Дени1С 1 год назад
На рассмотрении
проблема будет исправлена в версии 17.01

временное решение:

Функция ОпределитьПартнераEDIПоСообщениюМеркурий(Знач Сообщение)
    
    Перем ТочкаДоставки, ТочкаДоставкиПолностью;
    
    ПартнерEDI = Неопределено;
    
...
        
        //для определения Партнера - воспользуемся EDI логикой
        Если ЗначениеЗаполнено(Сообщение.ХозяйствующийСубъектПолучатель1С) Тогда 
            ПартнерEDI = ОсновнойМодуль.ПолучитьЗначениеСвойстваОбъектаEDI(Сообщение.ХозяйствующийСубъектПолучатель1С, "ПартнерКонтрагента");
        КонецЕсли;
        Если НЕ ЗначениеЗаполнено(ПартнерEDI) И ЗначениеЗаполнено(Сообщение.ПлощадкаПолучатель1С) Тогда 
            ПартнерEDI = ОсновнойМодуль.ПолучитьЗначениеСвойстваОбъектаEDI(Сообщение.ПлощадкаПолучатель1С, "ПартнерКонтрагента");
        КонецЕсли;
        
        //+++СКБ_КОНТУР_СЕВ_20062019
        //Если НЕ ЗначениеЗаполнено(ПартнерEDI) Тогда        //БЫЛО
        Если НЕ ЗначениеЗаполнено(ПартнерEDI) И ЗначениеЗаполнено(Сообщение.ПлощадкаПолучатель1С) Тогда //СТАЛО
        //---СКБ_КОНТУР_СЕВ_20062019    
            ТочкаДоставки = ОсновнойМодуль.НайтиОбъектПоЗначениюСвойства("ЮрФизЛицо_ТочкиДоставки",Сообщение.ПлощадкаПолучатель1С);
            Если ЗначениеЗаполнено(ТочкаДоставки) Тогда
                ТочкаДоставкиПолностью = ОсновнойМодуль.ПолучитьЭлементСправочника("ТочкиДоставкиСторонние",ТочкаДоставки);
                ПартнерEDI = ТочкаДоставкиПолностью.Партнер;
            КонецЕсли;
        КонецЕсли;
        
    КонецЕсли;
    
    Возврат ПартнерEDI;
    
КонецФункции

Спасибо!

Проверю как получим новый входящий ВСД.

Не помогло это решение.

решение только такое, у других клиентов оно работает.

возможно, вы где-то ошиблись.

заполнение колонки партнер никак не влияет на гашение входящих ВСД.

Эта проблема исправлена в 17 релизе. 

Сервис поддержки клиентов работает на платформе UserEcho