Ваши комментарии

1.это единственный вариант решения данной проблемы

2."Изменение уровней иерархического справочника продукции для существующей номенклатуры невозможно"

у вас в вебе GUID 4 уровня уже есть, вот он и ругается что изменять 3 уровень у уже существующей опубликованной номенклатуры нельзя.

Вам необходимо эту позицию не переопубликовать (внести изменения в уже существующий 4 уровень), а создать новый 4 уровень, опубликовать позицию с нуля уже с верным 3им уровнем, тогда вы сможете погасить ВСД

1.нужно договориться с поставщиками чтобы все отправляли одинаковый 3тий уровень, это единственный вариант

2.заново опубликовать свою продукцию и погасить

С 20.08 разработчики Меркурий вводят запрет на редактирование первых трех уровней элемента справочника наименований продукции. Это значит, что в справочнике нельзя будет редактировать вид продукции (3 уровень) у имеющейся позиции.

Источник: http://www.fsvps.ru/fsvps/news/31360.html


Вам необходимо опубликовать продукцию заново уже с верными данными

1.обновиться на 17 версию

2.скорее всего проблема в том что у вас одна и та же партия используется в нескольких производствах, и после того как в одном месте с партией что то сделали (отгрузили, списали) у неё изменился UUID (версия записи), но в других операциях остался старая версия партии, и выдаёт ошибку

можете прислать скриншон с одной позиции, с каким 3им уровнем вы сопоставили в базе и информацию по этой же позиции 3го и 4го уровни который вам прислал поставщик, именно гуиды, то что 2106 это ничего не значит, вон взять хоть код 0402, видов продукции под таким кодом порядка 15 штук и у всех разные гуиды

можете приложить ещё xml файл запроса который приходит к вам от поставщика (этот вариант будет даже лучше)

Вы указали один 3 уровень, производитель другой, вот они и разные, и оба из большого меркурий. Нужно просто договориться с поставщиком чтобы у этой продукции был один 3 уровень

проблема в том, что GUID 3 уровня у пришедшей позиции и номенклатуры в вашей базе, которую вы пытаетесь связать, разный. Вот модуль и говорит, что они разные и предлагает вам заменить у вас в базе GUID 3 уровня на тот который пришёл Вам во входящем ВСД, либо оставить как есть

в ближайшем будущем меркурий будет работать отдельно от модуля EDI

можете отредактировать уровни как вам необходимо в плагине Плагин_МеркурийИзменитьИсходящееСообщениеXDTO



Сервис поддержки клиентов работает на платформе UserEcho